当前位置: 56net亚洲必嬴 > 服务器&运维 > 正文

Cisco调换机配置SSH+Telnet+改过名称,Ciscossh

时间:2019-11-01 11:47来源:服务器&运维
Cisco交流机配置SSH+Telnet+改进名称,Ciscossh Hello我们好,笔者是Lionel,明天本身给大家带来Cisco路由器配置SSH,Telnet和改变交流机名字的科目。 看自身上边操作 第生龙活虎大家运行交流机

Cisco交流机配置SSH+Telnet+改进名称,Ciscossh

Hello我们好,笔者是Lionel,明天本身给大家带来Cisco路由器配置SSH,Telnet和改变交流机名字的科目。
看自身上边操作
第生龙活虎大家运行交流机,见到       Switch>
下面的单词(运维过程比非常慢)
配置SSH
小编们各种输入下边的通令,前边有中文注释命令是何等看头,大家能够依照自身要求打开安插。
Switch>en                                             进入特权方式
Switch#conf t                                         走入配置形式
Switch(config)#int vlan 1                             进入vlan 1
Switch(config-if)#ip add 192.168.6.X 255.255.255.0    设置IP和掩码
Switch(config-if)#no shut                             生效
Switch(config-if)#exit                                退出
Switch(config)#ip domain-name cisco.com               设置域
Switch(config)#crypto key generate rsa                配置加密方法为XC60SA
Switch(config)#aaa new-model                          启用AAA认证
Switch(config)#username admin password admin          设置SSH客户名和密码
Switch(config)#enable secret cisco                    设置特权方式密码
Switch(config)#ip ssh time 60                         设置SSH登入超时时间
Switch(config)#ip ssh authentication 4                设置签到失败尝试次数
Switch(config)#line vty 0 4                           步入Telnet接口配置方式
Switch(config-line)#transport input SSH               在Telnet接口方式下行使SSH认证
Switch(config)#ip ssh version 2                       若要用SSH2,配置SSH的版本号
Switch(config)#end                                    结束
Switch#wr                                             写入保存

到这步大家wr写入保存,达成了SSH的安插,大家在本土配置一个和调换机同一网段的内网IP。访谈这么些交流机的IP。
软件用PUTTY就可以。

配置Telnet
布局Telnet的指标是为了多少沟通机版本低不帮忙SSH,所以我们要用Telnet连接交流机。
输入以下命令
设置域名:Router (config)# ip domain-name cisco.com
进入Telnet接口配置形式:Router (config)# line vty 0 4 
Router (config-line)# transport input telnet
Router (config-line)# password admin
Router (config-line)# login
Router (config-line)# exit
Router# wr
那样重启大家就能够用Telnet连接了。

安装沟通机名称

Switch(config)#hostname 名称
只必要一条命令就可以修正名称,大家也得以经过其他办法修改,具体看交流机的版本。

如上正是本周带来的科目,想了然越多教程能够关切我们的官方网站和

Hello大家好,小编是Lionel,明菲律宾人给我们带来Cisco路由器配置SSH,Telnet和校订沟通机名字的教程。...

在trunk链路聚合中删去外来客商使用的管理器所在的vlan(多线)
Switch(config)#interface port-channel 1
Switch(config-if)#switchport trunk allowed vlan remove 2

操作
 命令
 
安装端口为Access端口
Switch(config)#interface range g0/21-22
Switch(config)#switchport mode access
 
安装端口为Hybrid端口
Switch(config)#interface range g0/21-22
Switch(config)#switchport mode hybrid
 
安装端口为Trunk端口
Switch(config)#interface range g0/21-22
Switch(config)#switchport mode trunk
 
恢复端口的链路类型为缺省的Access端口
 undo port link-type
 
三类别型的端口能够共设有风华正茂台以太网沟通机上,但Trunk端口和Hybrid端口之间无法直接切换,只可以先设为Access端口,再设置为任何项目端口。举例:Trunk端口不可能直接被设置为Hybrid端口,只好先设为Access端口,再设置为Hybrid端口。

2.Telnet

记不住Cisco简短布署命令的相爱的人们有方便了!!!
以下是有关思科配备一些粗略的安插命令,初学的意中大家没记住的能够来看看啊!

2.查看端口名字

(复苏配置文件)
IOS# copy tftp startup-config    (那是一个交替的长河)
IOS# copy tftp running-config   (那是三个统后生可畏的经过)

Switch(config)#interface range(范围)fastEthernet 0/1,f0/4(把四个接口参与同一个节制)
Switch(config-if-range)#channel-group (通道组)1 (顾客自定义)mode on
Switch(config-if)#switchport mode trunk 把接口情势改成truck

内需在意的是:Access端口参加的VLAN必需已经存在並且不可能是缺省VLAN;Hybrid端口参预的VLAN必需已经存在;Trunk端口参与的VLAN不能是缺省VLAN。

3.TFTP中得以保留 路由器的 IOS镜像 (备份)

        • CISCO:
  • Switch>客商形式

  • Switch>**enable

    * Switch#特权情势

  • Switch#configure terminal

  • Switch(config)#大局配置格局
  • Switch(config)#interface fastEthernet 0/1
  • Switch(config-if)#接口方式
  • Exit重临上一形式
  • 改主机名
  • Switch>顾客方式
  • Switch>enable
  • Switch#特权情势
  • Switch#configure terminal
  • Switch(config)#大局配置格局
  • Switch(config)#hostname+自定义顾客名
    • Switch#show running-config 查看配置消息
  • Switch#show mac-address-table查看mac地址
  • Switch#show version 查看IOS版本消息
    • Switch (config)#(+no 废除密码)
  • enable password(不用写数字) 123 配置顾客走入特权格局的公开密码
  • Switch (config)#(+no 撤消密码)enable secret(不用写数字) 456 配置顾客步向特权方式的密文密码

  • Switch#copy running-config startup-config/ write/wr 保存当前布署

  • Switch(config-if)#no ip address 删除ip地址,删除命令用no
  • Switch#reload 重启
  • Switch#show interfaces f0/1 switchport 查看接口参数(在调换机)
  • Switch#show interfaces f0/1 查看接口参数(在路由器)
  • Switch(config-if)#switchport mode trunk 把接口情势改成truck
  • Switch(config-if)#switchport mode access 把接口方式改成access
  • Switch#show ip route 查看路由表
  • Router(config)#vlan +数字 创建vlan
  • Switch#vlan database vlan数据库(第三种创造vlan的措施)
  • Switch(config-if)#switchport access vlan +数字 将某接口参预vlan

  • 给三层交流机接口打802.1q封装(二层调换机自动学)

  • (可用三层与三层调换机之间的trunk连接)
  • Switch(config-if)#switchport trunk encapsulation dot1q
  • Switch(config-if)#switchport mode trunk

  • Switch(config-if)#ip address+ip+子网掩码 配置三层调换机ip

  • Switch(config-if)#no switchport 把二层接口变成路由接口
  • Switch(config)#ip routing 开启三层调换机的路由作用
  • Switch#show run 查看全数端口
  • *R1(config)#no ip routing 关闭路由功用
  • *R1(config)# ip default-gateway 192.168.0.254 在本设备安装要到达的网关
  • 查看完路由表后 查看优先级
  • Switch#show ip route
  • S 192.168.3.0/24 [1(优先数值)/0] via 192.168.1.2 数值越小越优先

  • *动态路由

  • 先把接口ip和网关配好
  • R6(config)#router rip (动态协议) 步向动态(rip)路由格局
  • R6(config-router)#version 2(步入版本2)
  • R6(config-router)#no auto-summary(自动协商)
  • R6(config-router)#network 192.168.4.0(发布所连互连网段)
  • *应用本机回环接口在rip中传递路由消息(制造虚构接口测验动态路由)
  • 步入本机回环接口并安装ip (loopback接口依托物理接口;只要物理接口激活,loopback接口就会ping通)
  • R6(config-router)#inter loopback 0 (客户自定义)
  • R6(config-if)#ip address 192.168.6.1 255.255.255.0
  • 在rip中公布回环接口所在网段
  • R6(config-if)#router rip
  • R6(config-router)#network 192.168.6.0
  • *配置远程登入(在器材里张开远程功用)
  • R2(config)#line vty 0 4(0~4人管理)
  • R2(config-line)#password 123(配置远程登陆密码)
  • R2(config-line)#no login(远程登入时无需密码)(细枝末节)
  • R2(config-line)#exit
  • R2(config)#enable password 456(配置走入特权密码)
  • *后来在pc机中采纳telnet命令测量检验
  • R1#telnet 192.168.4.2(要进去的配备接口ip)
  • ==============================
  • 1、连接wan网 DHCP
  • 三个网段分配三个DHCP池
  • DHCP(自动分配Ip)的布置:
  • Router(config)#ip dhcp pool xx 创设地址池,名叫xx
  • Router(dhcp-config)#network(互连网) 192.168.1.0 255.255.255.0 加多网段,(要给那些网段分配地址)
  • Router(dhcp-config)#default-router 192.168.1.254 钦命网关地址
  • Router(dhcp-config)#dns-server 8.8.8.8 指定DNS地址
  • Router(dhcp-config)#int f0/0 步入网关接口/vlan
  • Router(config-if)#ip address 192.168.1.254 255.255.255.0 配置网关地址
  • Router(config-if)#no shutdown 激活接口
  • Switch(config)#ip routing 开启三层调换机的路由作用
  • 去pc机步入接口输入CR-V6(config-if)#ip address dhcp (本事获得ip)
  • 设置静态路由(目的网段、子网掩码、下生龙活虎跳地址)
  • Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
  • Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1 (配置暗中同意路由)用于最后网络
  • Router(config)#ip route 0.0.0.0 0.0.0.0 +(自身的端口)f0/0 (吓黄金时代跳 在不理解对方接口ip时可用)
  • 2、创制内部服务器
  • 在三层交流机创立vlan池;DHCP地址保留二个地方为服务器用(工作者得到不到)
  • Switch(config)#ip dhcp excluded-address (肃清地方)192.168.10.1
    • trunk是用在一条链路中多少个vlan的通讯,也就是四个物理链路中开了众多个虚构的互不相干的链路! 首要用在交流机与调换机之间,交换机与路由器之间(交流机端口配置trunk)。
  • 在trunk链路中去除此而外来客户使用的微管理器所在的vlan(单线)
  • Switch(config-if)#(no)switchport trunk allowed vlan remove(去掉) 外来顾客利用的微型计算机

#sh int port-channel 查看“端口聚合/链路捆绑

4. 通过Ethernet上的TFTP服务器;

SWA#sh vlan
   default  Active  F0/1, F0/2, F0/3, F0/4, F0/5, F0/6, F0/7, F0/8
f是端口名子
    default  Active  Gi/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6, Gi0/7, Gi0/8
Gi是端口名字

ciscoasa>

  #show ip int bir   查看端口VLAN IP 开启状态总览

cisco>enable
cisco# config terminal
cisco(config)# line console 0            切换为调整台0号 线路安顿形式
cisco(config)# password  密码           设置密码
cisco(config)# login                              将决定台线路设置为登入需求输入口令 才具访谈(不然尽管设置密码也不须求输入)
cisco(config)# logging synchronous          任务令输入时,不会被系统弹出的打字与印刷音讯中断
cisco(config)# exec-timeout 0 0              超时自动撤销时间 意思是0分0秒
cisco(config)#end                    

以太网端口有三种链路类型:Access、Hybrid、Trunk。Access类型的端口只好属于1个VLAN,日常用于连接计算机的端口;Trunk 类型的端口能够属于多少个VLAN,能够吸收接纳和出殡和安葬八个VLAN的报文,日常用来调换机之间连接的端口;Hybrid类型的端口能够属于多少个VLAN,能够收到和出殡和安葬四个VLAN的报文,能够用来沟通机之间总是,也能够用于连接客商的微管理器。Hybrid端口和Trunk端口的差别之处在于Hybrid端口能够允许七个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

 

#show inventory 查看光模块显信

 

1.不同的vlan

 

Switch(config)#interface range g0/21-22
Switch(config-if-range)#channel-group 1 mode active
Switch(config-if-range)#exit

1. Console口接终端或运营终端仿真软件的管理器(第2回配置要运用此方式)

#show spanning-tree 查看生成树状态

#show access-list 查思想则状态

#show history 查看历史输入指令

#show errdisable recovery 查阅哪些爱抚会在逾期后可自动复苏

#show errdisable detect​查看 err-disabled 状态的原因

 

6.配置vlan的IP
s(config)#int vlan 6
s(config-vlan)#no shu
s(config-vlan)#ip add 10.2.20.1 255.255.255.254
SWA#wr
 7.配置沟通机的IP和网关

 配置调换机网关:Switch(config)#ip default-gateway 网关

switch(config)#int vlan 1
    设置ip地址和掩码:
switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
switch(config)#ip defaule-gateway 10.65.1.9
    查看当前安插:
switch#sh run

8.清除思科全体配置

SWA#del vlan.dat
SWA#reload

9.删减动态链接

Switch(config)#interface range g0/21-22
Switch(config-if-range)#no channel-group 1
Switch(config-if-range)#exit

10.设置vtp

switch(config)#vtp domain ;设置发vtp域名
switch(config)#vtp password ;设置发vtp密码
switch(config)#vtp mode server ;设置发vtp模式
switch(config)#vtp mode client ;设置发vtp模式

  11.设置Cisco交流机的IP和子网掩码

switch#conf t
    步入默许VLAN状态:
switch(config)#int vlan 1
    设置ip地址和掩码:
switch(config-if)#ip address 10.65.1.3 255.255.0.0
    设置switch的网关:
switch(config)#ip defaule-gateway 10.65.1.9
    查看当前布署:
switch#sh run
SWA#write

  12.Ciscotelnet登录方法

开始--cmd---telnet

13.思科封存方法

在全局配置方式下
Router#copy running-config startup-config //保存当前的布置

Router#write
也行

14.Cisco查看vlan

SWA#sh vlan

15.思科查看当前配备

   查看当前布置:
switch#sh run

      16.Cisco上涨出厂设置

  Switch#erase startup-config

  Switch#reload

有提醒要保存配置 就筛选no 

    17.Cisco将端口参加vlan

SWA(config)#int f0/5                        (f是端口号sh vlan能够看端口号,端口号是不一样等的我们的是Gi)
SWA(config-if)#switchport access vlan 2
SWA(config-if)#int f0/6
SWA(config-if)#switchport access vlan 2
SWA(config-if)#int f0/7
SWA(config-if)#switchport access vlan 2
SWA(config-if)# end
SWA#sh vlan
SWA#wr(保存)

    18.Cisco和Computer接法

率先那个软件不可能三番四次真实设备:
选拔黄金时代台PC,二个设备(调换机,路由器都行)
老是PC和设施,线缆选择金棕线缆,英语应该是console---调节台的乐趣。连接是,PC上采摘EscortS232接口,设备上采摘CONSOLE接口
连续几日好今后,双击PCLogo,伸开三个窗口,点击桌面(desktop),再选拔终端(terminal),点击OK,就足以了!

    19.Cisco进来

Switch>enable
Switch#

                                      20.Cisco格局

呵呵终于找到二个有关cisco的标题了。

爱人你好,小编就用作者要好的语言表明了哈,有一点点长哈,但必然帮您学懂哈。Cisco的路由器的客商分界面有以下两种:
1.顾客推行格局(User EXEC Mode)
2.特权实施格局(Privileged EXEC Mode)
3.全局配置形式(Global Configuration Mode)
4.监察情势(ROM Monitor Mode)     安ctrl + break
5.安装方式(Setup Mode)           先步入特权情势 在setup  就行
6.Boot模式(RXBoot Mode)

常用的是1、2和3。上面小编就来标准答复你问的。

路由器生龙活虎开机,进去的特别分界面提醒符是“>”,举例像这么子哈,“Router>”这几个正是客户执行方式,也是低于级其他形式,它只同意有限数量的骨干监视命令,该方式下不允许别的会改换路由器配置的下令。

那大家要配备路由器时该咋弄啊,那时候就亟须先得进来到“特权实行方式”了(也正是在客商实践情势下输入“enable”命令)。现身像这么的提醒符“#”,比如“Router#”。比较顾客实行情势,它提供越来越多的一声令下和权杖,比方debug命令,和越来越留意的测量试验等。

有关“全局配置情势”,是铺排(全局)系统和呼应的实际细节配置(譬喻接口ip、路由和睦这么些)时步入的分界面,在那布置的东东是熏陶全局的。全局配置方式的唤起符是那样的“(config)#”,例如自身这里举的例就该是“Router(config)#”。

而要配置具体的东东就得从大局配置形式下步向到相应的子配置形式下。比如:
Router(config-if)# //具体的接口配置
Router(config-line)# //line形式配置,比方console和vty那几个哈
Router(config-router)# //路由器方式,比如配置路由协和时

百度精通无法回帖功用缺乏强盛,不然作者得以另行更了不起的排版和符号,好让朋友更加的轻易精晓。

粗略总计下您的标题就是,特权实践形式首倘诺用来调解的,全局配置方式是用来安插的。而且他们的涉及,要达到全局配置形式,你一定要先得处在特权施行格局哈。

而相应的指令见下边哈:

Router>
Router>enable //将从客户实行方式步向到特权执行方式
Password: //即便对特权实行情势设置了密码的话,步向时还得输入密码哈
Router#
Router#exit //将从特权实施格局退回到客户推行方式
Router>

//上边笔者亲自去做怎样从顾客实践格局一步步达到全局配置情势哈:
Router>enable
Router#
Router#configure terminal
Router(config)#

 

                                        21.Cisco配置vlan并保存

SWA#vlan database
SWA(vlan)#vlan 2
SWA(vlan)#vlan 3
SWA(vlan)#exit
SWA#write

                                        22.Cisco配置远程登陆

111(config)# line vty 0 4     步入设想线程配置形式,在此个情势里可对
telnet功能进行配备
111(config-line)# login
111(config-line)# password XXX 配置telnet密码,暗中认可的网络设施telnet的效果是
关闭的,配了密码然后会活动展开
111(config)# enable password XXX 配置步向enable方式的密码, 区分朗朗上口写
111(config)# enable secret XXX 配置走入enable情势的密码,是加密的密码,show
run是看不见的
111(config)# line console 0
111(config-line)# login
111(config-line)# password XXX 配置步入客商格局的密码
111(config-line)# logging synchronous 输入同步
111(config-line)# exec-timeout 0 0 禁绝因为生龙活虎段时间没有输入而跳出
111#SWA#write保存配置
                               23.Cisco批管理登录

off  
echo set sh=WScript.CreateObject("WScript.Shell") >telnet_tmp.vbs  
echo WScript.Sleep 300 >>telnet_tmp.vbs  
echo sh.SendKeys "open 你的网络设施telnet登陆IP" >>telnet_tmp.vbs  
echo WScript.Sleep 300 >>telnet_tmp.vbs  
echo sh.SendKeys "{ENTER}" >>telnet_tmp.vbs  
echo WScript.Sleep 300 >>telnet_tmp.vbs  
echo sh.SendKeys "你的客户名{ENTE瑞虎}">>telnet_tmp.vbs  
echo WScript.Sleep 300 >>telnet_tmp.vbs  
echo sh.SendKeys "你的密码{ENTECRUISER}">>telnet_tmp.vbs  
echo WScript.Sleep 300 >>telnet_tmp.vbs  
echo sh.SendKeys "conf{ENTER}">>telnet_tmp.vbs  
start telnet  
cscript //nologo telnet_tmp.vbs  
del telnet_tmp.vbs 
                                24.Cisco删除vlan

jjf{cinfig}#no vlan 10   删除vlan10
jjf{cinfig}#end          回到特权情势
jjf{cinfig}sh vlan      查看vlan  
SWA#write

                              25.Cisco设置trunk干线

安装干线trunk
    将接二连三多个调换机的端口设置成trunk。
SWA(config)#int f0/8
SWA(config-if)#switchport mode trunk
SWA(config-if)#switchport trunk allowed vlan 1,2,3(只同意vlan 1 2 3 在此条个trunk链路上走,这一个正是vlan修剪。)
SWA(config-if)#switchport trunk encap dot1q(可以毫无dot1q是vlan中继商业事务(802.1q)平时交换机都以自带的)
SWA(config-if)#end
SWA#sh run

SWB(config)#int f0/1
SWB(config-if)#switchport mode trunk
SWB(config-if)#switchport trunk allowed vlan 1,2,3
SWB(config-if)#switchport trunk encap dot1q
SWB(config-if)#end
SWB#sh run
26.Cisco型号

思科 Catalyst 2960G-24TC-L 贰15个以太网10/100/1000端口,此中有4个为两用端口

                                  26.Cisco远程登陆pingIP地址(可做批管理)

off
echo set sh=WScript.CreateObject("WScript.Shell") >telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "open 登录交流机IP地址" >>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "{ENTER}" >>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "用户名{ENTER}">>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "登陆密码{ENTE汉兰达}">>telnet_tmp.vbs
echo sh.SendKeys "ping 192.168.0.2{ENTER}" >>telnet_tmp.vbs
start telnet
cscript //nologo telnet_tmp.vbs
echo del telnet_tmp.vbs
                               27.思区长途沟通机登录配置

 1.进去vlan 1接口格局
switch(config)#interface vlan 1
2.打开vlan 1端口
switch(config-if)#no shutdown
3.配置vlan 1的IP地址
switch(config-if)#ip address 172.16.10.99 255.255.255.0
三、配置沟通机Telnet登陆
  1.在全局配置情势下设置特权情势口令
switch(config)#enable password cisco
2.在大局配置情势下设置设想终端(Virtual terminal)的路线号
switch(config)#line vty 0 4
switch(config-line)#
3.在路经布署格局下设置通过编造终端登入的客户口令为net(必需设置口令才具动用管理IP远程登陆交流机)
switch(config-line)#password net
4.在线路布署情势下选拔login命令测量试验是还是不是足以远程登陆
switch(config-line)#login
switch(config-line)#
只要未有现身提醒,表明设置成功,假使现身五行提示,表明设置有误。
四、使用PC1机远程登入交流机
1.将PC1用直通线连接到沟通机的法斯特Ethernet0/3端口。
2.开垦PC1的“桌面”上的“IP配置”,选拔静态配置,设置IP地址为172.16.10.100,子网掩码为255.255.255.0。
3.开荒PC1的“桌面”上的“命令提醒符”。
4. 在指令提示符中使用telnet命令远程登陆调换机(沟通机管理IP地址为172.16.10.99)
PC>telnet 172.16.10.99
Trying 172.16.10.99 ...
User Access Verification
Password:
在接下去出现的password提醒文字后输入前边调换机上设定的telnet登入口令net(该口令输入时不会展现其余标志),就可以步向沟通机的顾客配置形式。
5.输入特权形式口令步向全局配置情势
在顾客配置方式下输入enable命令,再后输入所陈设的特权格局口令cisco(该口令输入时不会来得任何标志)就能够进入全局配置情势举办一而再再而三互联网设置。
Switch>enable
Password:
                                     28.             思科重启

思科有所的重启命令都以reload

                                   29.           远程登录调换机可做批管理

off
echo set sh=WScript.CreateObject("WScript.Shell") >telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "open 192.168.6.100" >>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "{enter}" >>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "root{ENTER}">>telnet_tmp.vbs
echo WScript.Sleep 300 >>telnet_tmp.vbs
echo sh.SendKeys "jjf1{ENTER}">>telnet_tmp.vbs

start telnet
cscript //nologo telnet_tmp.vbs
echo del telnet_tmp.vbs

Translating "enb"...domain server (255.255.255.255) 快捷键 
ctrl shift + 6        no ip domain

aaa authentication ssh console LOCAL

不等vlan要求路由
在路由的端口设置四个IP段
调换机模拟器实验六

 

5.沟通机展现命令

ciscoasa(config)# http 172.16.0.0 255.255.255.0 guanli                           在管理口设置可治本的IP地址

#sh int etherchannel sum 查看“端口聚合/链路捆绑

1.LOCAL

#show int status 查看端口状态总览


路由器 特权密码的安装:

使能密码配置::enable secret 123就行了。
常常密码配置是:enable password 123,不过这种方法会在show的时候见到,而enable secret就不会被见到。 借使三种都配备,会利用secret那几个,优先级高。

4.开立端口的链路类型

ciscoasa(config)# http server enable                                                         开启HTTP服务

表1-9 设置以太网端口的链路类型

布署vty的连年情势 Router> enable 
Router# configure terminal 
Router(config)# line vty 0 15                 配置 0—15 号设想线路
Router(config-line)# transport input ? 连接服务器的多少公约
all All protocols                        全体包含
none No protocols 
ssh TCP/IP SSH protocol      ssh加密传输
telnet TCP/IP Telnet protocol telnet 无加密传输

缺省景观下,端口为Access端口。

ciscoasa(config)# webvpn                                                                         进入WEBVPN模式

交流机展现命令:
switch#write ;保存配置新闻
switch#show vtp ;查看vtp配置音讯
switch#show run ;查看当前配备新闻
switch#show vlan ;查看vlan配置新闻
switch#show interface ;查看端口音信
switch#show int f0/0 ;查看钦赐端口音信

username admin password cisco privilege 15

3.创设动态链路聚合

1.率先要创制意气风发台TFTP服务器,能够在局域网络内

推行了本配置,当前以太网端口就足以转账钦命VLAN的报文。Hybrid端口和Trunk端口能够参与到多少个VLAN中,进而完成本调换机上的VLAN与对端交流机上同样VLAN的互通。Hybrid端口仍然为能够安装什么样VLAN的报文打上标签,哪些不打标签,为实现对不相同VLAN报文推行不一致管理流程打下基础

 

 

那是最要紧、最广大的诀要。

4.开机辅导时直接从 TFTP 加载 IOS

4.用本地客户认证

ciscoasa(config-if)# no shutdown                                                              激活接口

domain ccie.com

2. AUX口接MODEM,通过话线与天涯的终点或运转终端仿真软件的微管理器相连;

Router(config) #ip ssh ?                                             5.别样设置
authentication-retries    Specify number of authentication retries 允许顾客认证尝试的最大次数
time-out        Specify  SSH time-out interval                                          配置SSH登录超时时间
version     Specify protocol version to be supported                        ssh的版本

图片 1

        出于远程管理路由器的主旨必要,每多个互连网管理员都不得不安插路由器使之能够利用轻巧网络管理左券(SNMP)。轻松网络管理左券(SNMP)提供了远程监察和控制作用,在Cisco路由器中包含了三个SNMP代理和保管音讯库(MIB)。它应用网管服务器作为入口点进行互联网管控,能够配备路由器向网管服务器发送管理新闻。因为急需经过互连网远程访谈管理路由器,因而带来了重重的新余危害。对此,在实行配置时必得确认保证独有授权客商能够运用它。
1.配置路由器尚可SNMP的基本命令
snmp-server community public RO
允许别的付出共用字符串(community string)为public的服务器端软件扩充读访谈。
snmp-server community private RW 允许别的付出共用字符串为private的劳务器端软件拓宽读和写访谈。
        为共用字符串选择健康的口令是老大关键的。上述例子中的public和private那样的共用字符串是不行大面积的口令,客户在安顿本身的设施时应丢弃使用它们。别的,如若也许的话,应该幸免对富有的路由器使用同意气风发的共用字符串,尽量为每贰个配备使用差别的共用字符串。不要让只读共用字符串与读/写的共用字符串相近,相同的时间还要准期修正口令。
2.安顿能访谈路由器的田管服务器
3.配置路由器向网管服务器发送报警音讯
应用SNMP的trap质量,当有人试图用不得法的共用字符串发送SNMP指令时,路由器能够向网管服务器发送报警新闻,但必要网管服务器上安装有CiscoWorks或相符的软件。
snmp-server enable traps
布局路由器使用trap,假设不被激活,未有trap向前转载。
snmp-server trap-authentication
配备路由器假使共用字符串的印证失利,发送五个trap。
snmp-server host 159.226.244.20 
布置路由器向内定主机发送trap。

3.SSH

cisco>enable
cisco#config terminal
cisco(config)#line vty 0 15 对vty0到15号 线路开展安顿(最大允许15个体同一时间登录,VTY线路的编号)
cisco(config)#password 密码 设置密码
cisco(config)#login(local)将决定台线路设置为登入须要输入口令 技术访问(不然即使设置密码也不须要输入)
                                                  假诺设置 local 则指明使用本地数据库实行身份验证,就要输入 顾客名 和 密码

 

 

对asa设备开展安插 telnet  ssh 方式

那用WEB访谈的顾客名是什么?

内需安装三个15级的顾客

4.LDAP

编辑:服务器&运维 本文来源:Cisco调换机配置SSH+Telnet+改过名称,Ciscossh

关键词:

  • 上一篇:没有了
  • 下一篇:没有了